AWS Security ChangesHomeSearch

AWS dlami: Move PyTorch 2.9 to supported DLAMIs; limit CVE notice to 2.10-2.12

Service: dlami · 2026-10-20 · Security-related medium

File: dlami/latest/devguide/dlami-support-policy-table.md

Summary

Updates the unpatched-CVE notice to PyTorch 2.10 through 2.12, moves the PyTorch 2.9.0 row from the unsupported table into the supported/current table, and adds PyTorch 2.9 x86 and ARM64 release-note links to the archived-versions list.

Security assessment

The diff adjusts a support-policy table that flags DLAMI versions containing known unpatched CVEs, moving PyTorch 2.9 out of the affected set and into the supported table. This is security-relevant lifecycle/patch guidance for image consumers, though no specific CVE id is referenced.

Evidence

+PyTorch DLAMIs for versions 2.10 through 2.12 (PyTorch 2.10, 2.11, and 2.12) contain known common vulnerabilities and exposures (CVEs) that cannot be patched. Because we maintain a separate DLAMI currency release for each PyTorch version, we do not backport security fixes to these images.

Diff

diff --git a/dlami/latest/devguide/dlami-support-policy-table.md b/dlami/latest/devguide/dlami-support-policy-table.md
index c6e7530..8ad84b0 100644
--- a//dlami/latest/devguide/dlami-support-policy-table.md
+++ b//dlami/latest/devguide/dlami-support-policy-table.md
@@ -13 +13 @@ For more details see the [Support Policy](https://docs.aws.amazon.com/dlami/late
-###### Security patches not available for PyTorch 2.9 through 2.12 DLAMIs
+###### Security patches not available for PyTorch 2.10 through 2.12 DLAMIs
@@ -15 +15 @@ For more details see the [Support Policy](https://docs.aws.amazon.com/dlami/late
-PyTorch DLAMIs for versions 2.9 through 2.12 (that is, PyTorch 2.9, 2.10, 2.11, and 2.12) contain known common vulnerabilities and exposures (CVEs) that cannot be patched. Because we maintain a separate DLAMI currency release for each PyTorch version, we do not backport security fixes to these images.
+PyTorch DLAMIs for versions 2.10 through 2.12 (PyTorch 2.10, 2.11, and 2.12) contain known common vulnerabilities and exposures (CVEs) that cannot be patched. Because we maintain a separate DLAMI currency release for each PyTorch version, we do not backport security fixes to these images.
@@ -28 +27,0 @@ PyTorch |  2.10.0 |  13.0 |  2026-01-21 |  2027-01-21
-PyTorch |  2.9.0 |  13.0 |  2025-10-15 |  2026-10-15  
@@ -46,0 +46 @@ Framework |  Current version |  CUDA version |  GitHub GA |  End of patch
+PyTorch |  2.9.0 |  13.0 |  2025-10-15 |  2026-10-15  
@@ -119,0 +120,8 @@ Release notes for DLAMI versions that are no longer supported. These archives pr
+  * [GPU PyTorch 2.9 (Ubuntu 24.04)](./aws-deep-learning-x86-gpu-pytorch-2.9-ubuntu-24-04.html)
+
+  * [GPU PyTorch 2.9 (Amazon Linux 2023)](./aws-deep-learning-x86-gpu-pytorch-2.9-amazon-linux-2023.html)
+
+  * [ARM64 AMI GPU PyTorch 2.9 (Ubuntu 24.04)](./aws-deep-learning-arm64-gpu-pytorch-2.9-ubuntu-24-04.html)
+
+  * [ARM64 AMI GPU PyTorch 2.9 (Amazon Linux 2023)](./aws-deep-learning-arm64-gpu-pytorch-2.9-amazon-linux-2023.html)
+